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Installation 

HWMonitor Pro is available as a setup version (that does automatically install the 32-bit or the 

64-bit binaries depending on your Windows version, creates the application entries in start 

menu and on desktop) and as a .zip file that contains the two binaries (portable, no 

installation). 

 

▪ Before Installing 

For security reasons, before opening the installation file (either the .exe or the .zip), please 

check the SHA256 checksum of the file that you’ve downloaded. In order to achieve that, open 

a command prompt (CMD command), then type :  

certutil -hashfile FilenameWithCompletePath SHA256 

For example : “certutil -hashfile c:\tools\cpuid\hwmonitor-pro_1.58.zip SHA256”. 

then compare the output with the checksums list (please check the extension to be sure that 

you do the right comparison). 

 

If the checksum is not the exact same, please do not open the downloaded file, and re-

download it directly from our website. 

 

▪ Installation 

If you’ve chosen the zip file, unzip the file in a folder and run the « x64 » version. If it does not 

start, this may mean that you are using a Win32 version of Windows, and in that case run the 

« x32 » version of the executable. 

If you’ve chosen the Setup version, run the executable file and let it guide you through the 

installation process. If you already have a registration key, the program should automatically 

find it. If not, you can either copy the pvk file in the user folder (Menu Tools -> Open User 

Folder), or re-enter the registration key (Menu Register -> Enter Registration Key). 

If after all those steps your key is still not recognized by the newly installed version, please read 

the Registration paragraph. 

 

▪ Removal 

You can remove the program either from the Add or Remove Programs window (from Settings, 

Control Panel), or choose Uninstall HWMonitor Pro from Start menu, Programs, CPUID. Please 

note that the directory CPUID won't be deleted since it contains the ini file and possibly your 

registration key. 

https://download.cpuid.com/checksum.txt
https://www.cpuid.com/softwares/hwmonitor-pro.html


 

Interface customization 

▪ Themes (View -> Theme) 

Three themes are available : default (classic Windows), Dark and Blue. 

 

Blue theme 

▪ Editable labels (F2) 

Sensor labels can be manually edited. To achieve that, select the sensor line, then press F2 or 

right-click (floating menu) -> Edit Label to activate the edition. You can also select View in the 



main menu, then Edit Selection Label. Labels can also be restored to their original value by 

selecting Restore Label in the floating menu. 

 

Data logging 

HWMonitor PRO includes multiple data logging capabilities : CSV (Comma-separated values) 

and graphs (as up to 2 sets of bitmap images). 

 

 

 

 Logging is triggered with the F5 key. Note that if the graph window is populated, it is also 

possible to log only the sensors that are reported in it, with the F6 key. 

 

 

Logging status in the status bar 

Real-time Graphs 

HWMonitor PRO 1.58 introduces a new feature that allows to display any sensor data in a real-

time graph. 



 

 

▪ Add a sensor to the graph Window 

Select the sensor, then right-click to make the floating menu appear and chose Add to Graph. 

The graph window will automatically appear. By default, all sensors of the same type 

(temperatures, clock speeds, powers …) are added to the same graph. 

 

▪ Customize the graph Window (“s”) 

Right-click on the graph Window then chose Settings (or press « s ») to display the graph 

settings dialog. For every curve displayed, it allows to move it (to a new or an existing graph), 

change its color, or delete it. 

 



Set Big Font increases the graph window font size to make it more readable on small side 

screens such as the Corsair Xeneon Edge. 

 

▪ Data logging (F6) 

The Data logging feature mentionned in the previous chapter can be limited to the sensors 

displayed in the graph window. In order to activate it, press the « F6 » key instead of the « F5 » 

key used to record all sensors. 

 

Remote Monitoring 

The remote monitoring feature in HWMonitor PRO is the ability to monitor one or several PCs 

on the same local network. PCs can be monitored from another PC, or from an Android mobile 

device thanks to the dedicated application. 

 

▪ Firewall considerations 

 

The instances of HWMonitor PRO exchange data through port 25021. In order to keep your 

system secure, firewalls programs are detecting non declared port accesses, henceforth, 

before using the remote features of HWmonitor PRO, you may need to declare the program to 

your custom firewall, or by default to Windows integrated firewalls. Depending on how your 

firewall is configured, you may be prompted to grant access to the program once the firewall 

requires it (typically as soon as you run a command related to remote monitoring). 

DO NOT disable or stop your firewall in order to make HWMonitor PRO remote feature work. 

Doing this would make your system vulnerable. 

 

▪ Remote a PC from another PC 

 

The steps to display the monitoring data of PC2 on PC1 are as following : 

a. Start HWMonitor PRO on PC1 and PC2. 

b. Switch to Listening mode to ON on PC2 (Network -> Listening Mode). When in listening 

mode, the program instance sends its data to all other instances connected to it.  

Note the IP address of PC2 (shown near to computer name at the root node). 

c. On PC1, open menu Network -> Connect -> IP Address and enter the IP address of PC2. 

A new root node for PC2 appears in HWMonitor PRO. 

Note that the remote sensors are also logged and can be displayed in the graph window. 



▪ Remote a PC from an Android device 

 

a. Install HWMonitor PRO for Android from the Google Play Store. 

b. Tap on the Add Device icon : 

 

c. Enter the IP address of the PC you want to connect to. It is not necessary to fill the 

name field, the program will automatically add the computer name at the first 

connection. 

 

 

d. Tap on the newly added device to connect to it. 

e. If the connection suceeds, the monitoring data appear. 

 

https://play.google.com/store/apps/details?id=com.cpuid.hwmonitorpro&hl=en


 

Note that this is also possible to remote monitor an Android device from a PC, or from 

another Android device. 

Tray Icons 

To add a sensor in the system tray, select it and right-click to make the floating menu appear, 

then choose Add to tray. You can also select View in the main menu, then Add Selection to 

Tray. 

 

If all icons are not visible, you can setup Windows in order it does always display all icons in 

the system tray : 

▪ Windows 10/11 : right-click on the task bar, choose Properties. In Personalization > 

Taskbar, select Other system tray icons, then enable HWMonitor PRO. 

 

▪ Windows 7 : right-click on the task bar, choose Properties. Click on the Customize 

button in the Notification Area group. Then check Always show all icons and 

notifications in the taskbar. 

 



Sensors tray icons can be individually removed by right clicking on each of them and choose 

Remove in the popup menu. Choose Remove All to remove all sensors icons from tray. 

 

 

 

HWMonitor PRO can be minimized to tray by choosing View menu, Minimize to Tray. If you 

check "Minimize to Tray" in the option dialog, the program will be minimized to tray everytime 

it is minimized. Once minimized to tray, double-click on the program tray icon to restore the 

interface. 

Registration 

You can test HWMonitor PRO for a 30-day period (that delay may vary). If you are willing to 

continue using the program after that time, you are required to purchase a license key. Before 

you purchase a license, we encourage you to read the program‘s End-User License Agreement 

(EULA). 

 

▪ Available licenses (may 2026) 

 

License name License features Price Purchasing link 

Standard 

• Unlimited usage duration. 

• One year unlimited updates (starting at 

the purchase date). 

• Up to 10 remote connections. 

€19.95- 

 

Extended 

• Unlimited usage duration. 

• Two years unlimited updates (starting at 

the purchase date). 

• Up to 20 remote connections. 

€34.95- 

 

 

https://www.cleverbridge.com/912/?scope=checkout&cart=98452
https://www.cleverbridge.com/912/?scope=checkout&cart=98453


▪ Use the registration key 

Once you’ve received your key by email, the process to use it is as following : 

a. Open the registration dialog (menu Register -> Enter Registration Key). 

b. Copy the registration code that is provided in the email that you received after the 

registration purchase, then paste it in the edit control of the registration dialog. Click 

on OK. 

c. Close HWMonitor PRO and run it again, or restart it (Tools -> Restart). Your version is 

now registered. 

d. Check your license at any time with Help -> About HWMonitor PRO. 

For more convenience, when you enter your registration code in the registration dialog, your 

personal key is saved in a file named hwmpro.pvk and stored in the same directory as the 

application. If you delete this file, you will have to enter your registration code again. 

Do not diffuse your pvk file or your registration code, that would be considered as a violation 

of the EULA. Your key contains all information that you’ve entered during the registration 

process, including your name and email address.  

If your key does not work, please check that your license is well in the updates range. If not 

and still no success, please contact us and don’t forget to mention your purchase reference ID 

in the message. 

 

▪ Updates 

The available licenses allow one or two years updates, meaning that you can use all versions 

of HWMonitor PRO released within one or two years after the purchasing of the license. For 

example, if you purchase a standard license in may 2026, you can use all versions of 

HWMonitor PRO released up to may 2027. 

All versions of HWMonitor PRO can be found at that address : 

https://www.cpuid.com/softwares/hwmonitor-pro.html#version-history 

 

Frequently Asked Questions (FAQ) 

 

1. What are the differences between HWMonitor PRO and the non PRO / free version of 

HWMonitor ? 

HWMonitor PRO shares the exact same hardware monitoring features as HWMonitor, and 

adds : 

▪ the remote monitoring (PC from PC and PC from Android device). 

https://www.cpuid.com/contact.html
https://www.cpuid.com/softwares/hwmonitor-pro.html#version-history


▪ Sensors as tray icons. 

▪ more advanced logging capabilities, like the graphs generator. 

 

 

2. I run the trial version of HWMonitor PRO. If I decide to purchase a license, will the 

registered version bring more features ? 

No, because it is made to evaluate the product before you buy it, the trial version includes all 

the features of the registered version. 

 

3. My license used to work, but I've downloaded the latest version of Hardware Monitor 

PRO, and at startup the programs asked my registration key again. When I enter it, it 

does not work and keeps asking for it. 

Your license included an update period (one year for the classic version, two years for the 

extended version), meaning that you can use all versions of HWMonitor PRO released during 

that period. You can either download a previous version from the versions history, either 

renew your license. 

 

4. I bought a new PC, can I use my existing license on it ? 

Yes, you can transfer your license to a new PC. Repeat the registration process on it. 

 

5. I’ve just bought a license but the registration process does not work and HWMonitor 

PRO keeps asking for it. 

Please contact us and don’t forget to mention your purchase reference ID in the message. 

 

6. I've changed one or more devices in my computer, but HWMonitor PRO keeps seeing the 

old devices. 

Go in Tools -> Open User Folder, then close HWMonitor PRO. Then, delete hwmprow.ini, and 

restart HWMonitor PRO. 

 

7. I’ve updated HWMonitor PRO and the remote connections does not work anymore. 

Please make sure that you use the same version of HWMonitor PRO on all machines. 

 

https://www.cpuid.com/softwares/hwmonitor-pro.html#version-history
https://www.cpuid.com/contact-us.html?subject=HWMONITOR-PRO


8. When I try to connect to a PC on my local network from my Android smartphone, I get 

an error message. 

The connection from an Android device requires to connect it to the local Wifi network. 

 

END-USER LICENSE AGREEMENT 

 

IMPORTANT - PLEASE READ CAREFULLY. 

This End-User License Agreement is a legal agreement between you (either an individual or a 

single entity) and CPUID for the CPUID software product identified above, which includes 

computer software and associated media and printed materials, and may include “online” or 

electronic documentation. By installing, copying, or otherwise using Hardware Monitor Pro, 

you agree to be bound by the terms of this agreement. 

 

▪ CPUID HARDWARE MONITOR PRO PRODUCT LICENSE 

CPUID HARDWARE MONITOR PRO is protected by copyright laws and international copyright 

treaties, as well as other intellectual property laws and treaties. CPUID HARDWARE MONITOR 

PRO is licensed, not sold. 

 

GRANT OF LICENSE 

This License Agreement grants you the following limited, nontransferable and non-exclusive 

rights : 

a. You may use CPUID HARDWARE MONITOR PRO for a non-renewable trial period of 30 

days, during which you have the right to make copies of CPUID HARDWARE MONITOR 

PRO for backup and archival purposes. During this trial period, you may install and use 

as many copies of CPUID HARDWARE MONITOR PRO as you need for your own, 

personal use. After this trial period, you must remove and destroy all copies of CPUID 

HARDWARE MONITOR PRO you have made. 

b. If you purchased a license of CPUID HARDWARE MONITOR PRO from CPUID, you may 

make copies of CPUID HARDWARE MONITOR PRO for backup and archival purposes. 

c. You may NOT sell, loan, donate, distribute, reveal or transfer in any way the license that 

you purchased from CPUID. 

d. You may NOT modify, reverse engineer or disassemble CPUID HARDWARE MONITOR 

PRO. 



e. You may install CPUID HARDWARE MONITOR PRO on as many PCs as allowed by the 

license, namely 10 for the standard version and 20 for the extended version. 

 

ALL SALES FINAL 

The purchase of CPUID HARDWARE MONITOR PRO is non-refundable and all sales are  

considered final. The trial period of CPUID HARDWARE MONITOR PRO is available for purposes 

of determining the suitability of CPUID HARDWARE MONITOR PRO, and so it is assumed that 

the purchase of CPUID HARDWARE MONITOR PRO was made following a thorough evaluation, 

and thus, no refunds shall be made. It is the buyer’s responsibility use the trial version for its 

intended purpose of determining suitability. Failure to evaluate CPUID HARDWARE MONITOR 

PRO prior to purchase does not alter this policy. 

 

COPYRIGHT 

CPUID is the sole developer and owner of CPUID HARDWARE MONITOR PRO. You, as user of 

CPUID HARDWARE MONITOR PRO, acknowledge and agree that CPUID HARDWARE MONITOR 

PRO is a proprietary product of CPUID under the French and European copyright laws and 

prevailing copyright laws throughout the world. You further acknowledge and agree that all 

right, title, and interest in and to CPUID HARDWARE MONITOR PRO, including associated 

intellectual property rights, are and shall remain with CPUID, and you agree not to contest 

CPUID's ownership or the validity of CPUID's rights. This License Agreement does not convey 

to you an interest in or to CPUID HARDWARE MONITOR PRO, but only a limited right to use 

the work, which is revocable in accordance with the terms of this License Agreement. 

You assume responsibility for the selection of this program to achieve your intended results, 

and for its installation and subsequent use. 

 

SOFTWARE DEFECT REPORTING 

If you find software defects in CPUID HARDWARE MONITOR PRO, you should report them to 

cpuz@cpuid.com. CPUID will evaluate them and, at its sole discretion, may address them in a 

future revision of CPUID HARDWARE MONITOR PRO. 

 

UPDATES 

The CPUID HARDWARE MONITOR PRO updates (including, but not limited to : bug fixes, 

upgrades, hot fixes, enhancements, modifications, new releases) are provided in the sole 

discretion of CPUID. If CPUID does provide you with any updates, such updates shall be subject 

to the terms and conditions of this Agreement (including the License) or such agreement, if 

any, which accompanies such updates. 



 

▪ RIGHTS OF CPUID 

You acknowledge and agree that CPUID HARDWARE MONITOR PRO contains proprietary 

material of CPUID protected under French and International copyright, trademark, and trade 

secret laws and conventions. All right, title, and interest in CPUID HARDWARE MONITOR PRO 

are, and shall remain, with CPUID. This Agreement does not convey to you any title or interest 

in and to CPUID HARDWARE MONITOR PRO only the limited right of use which may be 

terminated as provided for herein. You agree to use your best efforts to protect CPUID 

HARDWARE MONITOR PRO from use, reproduction, or other distribution except as specifically 

allowed under this Agreement. 

 

▪ TERM 

This license is effective until terminated. You may terminate this license at any time by 

returning all copies of CPUID HARDWARE MONITOR PRO, including merged portions of CPUID 

HARDWARE MONITOR PRO and all copies of documentation, to CPUID. This license will 

automatically terminate without notice from CPUID if you fail to comply with any term or 

condition of this Agreement. You agree upon such termination to destroy all copies of CPUID 

HARDWARE MONITOR PRO, including all copies of merged portions of the CPUID HARDWARE 

MONITOR PRO and all copies of documentation. 

 

▪ DISCLAIMER OF WARRANTY 

THIS SOFTWARE AND THE ACCOMPANYING FILES ARE PROVIDED "AS IS." CPUID AND ITS 

SUPPLIERS DO NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULTS YOU MAY 

OBTAIN BY USING THIS SOFWARE OR SUCH FILES. CPUID AND ITS SUPPLIERS MAKE NO 

WARRANTIES, EXPRESS OR IMPLIED, AS TO TITLE OR INFRINGEMENT OF THIRD-PARTY RIGHTS, 

MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE. The entire risk as to the 

quality and performance of CPUID HARDWARE MONITOR PRO is with you. Should CPUID 

HARDWARE MONITOR PRO prove defective, you (and not CPUID or any authorized dealers of 

CPUID products) assume the entire cost of all necessary servicing, repair, or correction. Some 

jurisdictions do not allow the exclusion of implied warranties, so the above exclusion may not 

apply to you. The foregoing does not affect or prejudice your statutory rights. Good data 

processing procedure dictates that any program be thoroughly tested with non-critical data 

before relying on it. 

 



▪ LIMITATION OF LIABILITY 

IN NO EVENT WILL CPUID BE LIABLE FOR ANY DAMAGES, INCLUDING ANY LOST PROFITS, LOST 

SAVINGS, OR OTHER INDIRECT, SPECIAL, EXEMPLARY, INCIDENTAL OR CONSEQUENTIAL 

DAMAGES, CLAIMS OR ACTIONS, ARISING OUT OF THE USE OR INABILITY TO USE CPUID 

HARDWARE MONITOR PRO, EVEN IF CPUID HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 

DAMAGES, CLAIMS OR ACTIONS. FURTHER, IN NO EVENT WILL CPUID BE LIABLE FOR ANY 

CLAIMS BY ANY OTHER PARTY ARISING OUT OF YOUR USE OF CPUID HARDWARE MONITOR 

PRO. SOME JURISDICTIONS DO NOT ALLOW THE LIMITATION OR EXCLUSION OF LIABILITY FOR 

INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE ABOVE LIMITATION OR EXCLUSION MAY 

NOT APPLY TO YOU. 

Nothing contained in this Agreement shall prejudice the statutory rights of any party dealing 

as a consumer. 

 

▪ INDEMNIFICATION 

You agree to indemnify, defend, and hold CPUID harmless from and against any claims or 

lawsuits, including costs and attorneys fees, that arise or result from the use of CPUID 

HARDWARE MONITOR PRO, provided CPUID gives you prompt written notice of any such claim, 

tenders to you the defense or settlement of such a claim at your expense and cooperates with 

you at your expense in defending or settling such claim. 

 

▪ GOVERNING LAW 

This Agreement shall be governed by and construed in accordance with the laws of France. 

Any legal proceedings arising under this Agreement shall be instituted only in the courts of 

France. 

The parties opt out of the United Nations Convention on the Sale of Goods and choose the 

laws of the France to apply to the Agreement and performance hereunder. 

 

▪ SEVERABILITY 

Should any term of this Agreement be declared invalid, illegal, void, or not enforceable by any 

court of competent jurisdiction, such provision shall be severed from this Agreement, and the 

remaining terms shall remain in full force and effect. 

 



▪ WAIVER 

The waiver or failure of either party to exercise or enforce in any respect any of its rights 

provided for in this Agreement or take action against the other party in the event of a breach 

of this Agreement shall not be deemed a waiver of any further right under this Agreement by 

such party or the right to subsequent enforcement of its rights or actions in the event of 

subsequent or the same breaches by the other party.  

 

▪ TRADEMARKS 

The names of companies and products mentioned on the Site or in the Materials may be the 

trademarks of their respective owners. 

 

▪ COMPLETE AGREEMENT 

BY USING THIS SOFTWARE YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, 

UNDERSTAND IT, AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. YOU FURTHER 

AGREE THAT THIS AGREEMENT IS THE COMPLETE AND EXCLUSIVE STATEMENT OF THE 

AGREEMENT BETWEEN YOU AND CPUID REGARDING THE SUBJECT MATTER HEREOF AND 

SUPERSEDES ANY PROPOSAL OR PRIOR AGREEMENT, ORAL OR WRITTEN, AND ANY OTHER 

COMMUNICATIONS BETWEEN YOU AND CPUID RELATING TO THE SUBJECT MATTER OF THIS 

AGREEMENT. 

 

▪ OPTIONAL SUPPORT SERVICES 

At your option and expense, and under a separate agreement, CPUID may provide you with 

support services related to your use of CPUID HARDWARE MONITOR PRO. Any supplemental 

software code provided to you as part of the support services shall be considered part of CPUID 

HARDWARE MONITOR PRO and subject to the terms and conditions of this License Agreement. 
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